System Requirements

PHP

PHP ScriptPHP 5.2.8 or later

MySQL server

PHP ScriptMySQL version 5.0 or later
(we recommend the very latest stable release)

PHP Decoders

PHP Script Portions of the Eicra Script code are encoded and require a PHP decoder in order to run. There are two available, both free.

PHP application script Zend Optimizer version 3.3.3 or later
OR
ionCube Loader version 4.4.1 (Higher)

MySQL server

Customized PHP web application Any web server daemon – such as Apache, nginx, IIS which is fully compatible with the required PHP configuration.

  • Operating System – Solaris, Linux, BSD, Windows or Mac
  • GD complied with your PHP Build – Yes
  • SendMail – Yes
  • PHP safe mode – OFF
  • The PHP function file_get_content() to be enabled
  • PHP memory_limit – 32M
  • PHP CURL – Yes
  • Minimum Web Space – 350 mb

Optional Server Requirements

Customized PHP web application The requirements listed below are only required if you decide to use one of the following optional modules.

  • Video Module
  • Music Module
    • PHP file_uploads – 1
    • PHP post_max_size – 10M
    • PHP max_input_time – -1
    • PHP upload_max_filesize – 20M
  • Short URL
    • mod_rewrite (Apache)
  • Facebook Connect

PHP Settings

Required PHP modules

Apache server settings

If you have mod_security installed on your apache web server, mod_security must be disabled or your Eicra Script files whitelisted (exempt from all mod_security rules).

Apache server settings

  • sql_mode : not strict

PHP cache and accelerators

SWIFT4 accesses many scripts spread across many files for each connection. We recommend that your web server has a PHP opcode cache, like xcache, apc or eaccelerator. We find that xcache is the easiest to install and most readily available.

Web Browser Requirements

The requirements for a web browser depends on what theme you are using for your site. The default theme we release has been tested to work on the latest versions of all the most common web browsers (eg. Firefox, IE8, Opera, Chrome etc…). For those that use Internet Explorer must have version 7 or higher installed in order to properly use all the features provided with v2.

Best PHP Script